How to make Intelijj IDEA took my jdk?

When compiling gives an error
java: javacTask: source release 1.8 requires target release 1.8

Changed 3 version jdk the error remains 2 versions 8 and 9.
June 10th 19 at 15:31
2 answers
June 10th 19 at 15:33
Solution
generally guslitsa just

the first link in the search

Check first
file->project settings->module->language level

if not helped then
File -> Settings -> Build, Execution, Deployment -> compiler -> compile java
to vydavit target bytecode version

if you are collecting mavena , please specify pom.xml

<build>
<plugins>
<plugin>
<groupid>org.apache.maven.plugins</groupid>
<artifactid>maven-compiler-plugin</artifactid>
<version>3.1</version>
<configuration>
<source>1.8
<target>1.8</target>
</configuration>
</plugin>
</plugins>
 </build>
June 10th 19 at 15:35
I use Intellij IDEA with jdk 9 works perfectly. Although I'm a beginner, and beginners luck :)

Find more questions by tags JavaIntelliJ IDEA