How to make access to the shared folder?

Good afternoon.
Has the following samba config. Every user has its home directory.

[homes]
path = /data/USERS/%U
browseable = yes
writable = yes
valid users = %U
public = no

There is a common directory /data/SHARE you want to give access to multiple users to this directory appeared in the user's home directory. How can I do this?

Add in the samb config-s next, but the directory does not appear.

[share]
path = /data/SHARE
browseable = yes
writable = yes
guest ok = yes
valid users = user1, user2
directory mask=0777
June 10th 19 at 15:49
3 answers
June 10th 19 at 15:51
The shared directory is to have Samba-client or expect to see this directory of FM users as a directory ?
In the first case, restart the service of Samba.
In the second podmanivaya directory need users, for example via fstab.
Shared directory does not appear in Samba client. It should be in the home directory of the user.
samb-I restarted after each change in the config.
Clients are all Windows. Directory mountasia as a network drive. - adelbert.Lueilwitz48 commented on June 10th 19 at 15:54
June 10th 19 at 15:53
Hi,
Comma here is not necessary, as I recall from mana:
valid users = user1 user2

And even if you define specific users, you can remove "guest ok = yes", as this is required for Windows "guests".
Nick does not matter, the main thing you need to keep this balloon appeared in the user's home directory. - adelbert.Lueilwitz48 commented on June 10th 19 at 15:56
,
the main thing you need to keep this balloon appeared in the user's home directory.

so I do not understand, if the user is in FM open \\server\share , it fails to open ? - adelbert.Lueilwitz48 commented on June 10th 19 at 15:59
It would be nice then to see the entire smb.conf and ls-al /data/ - maybe then something will clear up... - esperanza_Bartoletti commented on June 10th 19 at 16:02
open.
The situation is the following. Maybe bad explained.
Maunu the user's home directory as \\192.168.1.10\user1
This home directory is /data/USERS/%U
Everything is wonderful.
But I need to in this directory have a common folder /data/SHARE - nicklaus.OKeefe commented on June 10th 19 at 16:05
eeee , it does not happen. You have to have Samba resources:
- user directories
- shared catalogs

user1 192.168.1.10 opening in the same Explorer Windows, you'll see two directories, user1 and share. And share should be in uppercase, as you have it defined in the config: [share]

From user2 when opening .10, respectively, will also be two directories, user2, and share. - adelbert.Lueilwitz48 commented on June 10th 19 at 16:08
seems the only option to mount the share as a drive and make a symlink (Yes, in ntfs, they also have) from a directory on zemplenyi disk. - nicklaus.OKeefe commented on June 10th 19 at 16:11
June 10th 19 at 15:55
In the global section of the smb.conf put:
unix extensions = no

In the settings balls [homes] to set:
follow symlinks = yes
wide links = yes

To create symlinks to the right users:
ln-s /data/SHARE /data/USERS/User1/Share

Section [share] is not necessary in principle.

Find more questions by tags LinuxSamba