Why when the system appears the BIOS?

The situation is this: Some time ago, maybe a month? I installed on my computer Ubuntu next to Windows 10 (hard drive one). When the computer is booted I had a screen for selecting the system and all was well but a week ago I discovered strangeness.
At boot the image is lost BOIS, also when pressing on Del, F8, F12 computer does not respond - just a black screen, and then (somewhere in a minute), the image appears loading Ubuntu, the system boots and everything is fine, but there are three problems:
1. I can't go to BIOS;
2. I can't start the installed Windows;
3. A virtual disk with Windows (the place where Windows is installed and where you can go through the file Manager of Ubuntu) always have to "mount" again, or even access the Windows file I have.

Tried to search solution on the Internet on found. Also I tried to get the battery from the motherboard - didn't help either.
OC Ubutnu 17.04
PC configuration is this:
CPU: Intel(R) Pentium(R) CPU G4560 @ 3.50 GHz
RAM: DDR4 2133 kB 8084740
Motherboard: Gigabyte Technology Co., Ltd. H110M-S2H-CF
June 10th 19 at 15:58
4 answers
June 10th 19 at 16:00
Assume that the system was installed with UEFI.
Here, discussed in detail the process of installing two operating systems with this technology.
https://habrahabr.ru/post/165575/
Do not tell me where to find more detailed instructions for "repair"? - Ines_Abbott commented on June 10th 19 at 16:03
For starters, you need to understand what the necessary instruction.
And from Your description, I could only assume. - shawna_Mosciski commented on June 10th 19 at 16:06
I need that all would be back to what would have been a week ago, i.e. the choice of system at boot and the BIOS image) - Ines_Abbott commented on June 10th 19 at 16:09
Bootable flash drive bootable Linux, and then - on the instructions that I gave on top, run the loader. - shawna_Mosciski commented on June 10th 19 at 16:12
So I have to flash not to go. Just a black screen and all. Even if the hard drive is change to another - just a black screen - Ines_Abbott commented on June 10th 19 at 16:15
all I can advise is as soon as possible and many times to try in the BIOS to go :))
well, that is, once turned, immediately many times a combination of entrance into the BIOS. catch the moment should work. or not to give Ubuntu to boot, and off on the live that came recovery mode. and, read about uefi and secure boot, so we at least understand what it is. - shawna_Mosciski commented on June 10th 19 at 16:18
June 10th 19 at 16:02
Try to forcibly interrupt the download process several times (3-4) on this black screen.
Press Power as soon as the black screen appears again, press and hold Power until off (about 4 seconds)
After a few times it should start up in BIOS
June 10th 19 at 16:04
I have after installing win 10 on another ssd disc (7 on one, 10 on another) ceased to run win 7. The installation of win 10 was done on a clean hard disk and ssd disk with win 7 was disconnected from the system. Helped flashing BIOS a (win 7 was to run). After this incident, there was some hostility towards win 10.
June 10th 19 at 16:06
Helped reset the Bios via CMOS.

Find more questions by tags BiOSWindowsUbuntu