Redux naming convention (was setting, it was the solution, but not the same) as someone doing + a little bit about life?

Hi, comrades.
Was such subject
The application should consist of two pages:
  1. The first page displays a list of all bot users. For each user is displayed avatar name.
  2. The second page displays detailed information about the user and allows the administrator to edit the user name.

You can use any set of tools, frameworks, libraries and even languages. The details that are missing in the task, you can select in its sole discretion, including design.
The result is
The answer was

Thank you for your interest in our vacancy and for the time invested in the test tasks! We studied it carefully and decided I wasn't ready to move with you further on this opportunity.

We evaluate not only the performance of the solutions and programming style: simplicity and understandability of code, architectural decomposition, accuracy, and use the capabilities of the selected language. Your code, unfortunately, does not meet our expectations in this respect.

What we noticed:
  1. you have chosen architecture and use flux redux but network requests continue to do in components. method onSaveButton = () => {
  2. you colocate the names of the creators actions and actions that the application will cause a conflict of names for actions
What I think about it
  1. OK, tired it was evening, corrected :)
  2. Not exactly understood what he was writing, but overall it's probably about naming convention how to correct so that the issue number two arose? HOME_USERS_FETCH, USER_USERS_FETCH?
  3. Also, I would like to know General impressions of this Responsa, based on the formulation and solution? )
June 10th 19 at 16:11
0 answer

Find more questions by tags ReactRedux