How to fix the problem of Internet not working when connected to a PPTP VPN?

Set up the pptpd server centos 7
added iptables
-A INPUT-i eth0 -p tcp --dport 1723-j ACCEPT
-A INPUT-i eth0 -p gre -j ACCEPT


When connecting to the pptp connects and the connection is, but it stops the Internet to work, apparently the traffic is not wrapped in a network of pptp
how to fix?
April 19th 20 at 12:00
3 answers
April 19th 20 at 12:02
Solution
iptables-t nat -A POSTROUTING -s 192.168.0.1/24 -o eth0 -j MASQUERADE


Where the LAN change to your local IP PPTPD
April 19th 20 at 12:04
In the server settings need to enable routing of packets.
nano /etc/sysctl.conf

allow exchange between the network interfaces, add
net.ipv4.ip_forward = 1

Taken from here
www.unitec.com.ua/nastrojka-pptp-vpn-na-centos-7

Firewall -
firewall-cmd --permanent --add-masquerade
firewall-cmd --zone=public --add-port=1723/tcp --permanent
firewall-cmd --permanent --direct --add-rule ipv4 filter INPUT 0-p gre -j ACCEPT
firewall-cmd --permanent --direct --add-rule ipv6 filter INPUT 0-p gre -j ACCEPT
firewall-cmd --reload

Taken from here
https://sysadminblog.ru/linux/2018/07/11/prostoy-p...
This has been done.
Could not tarffic to transfer, now everything is OK - Magnolia.McKenzie commented on April 19th 20 at 12:07
April 19th 20 at 12:06
route add default gw metrics, etc.

Find more questions by tags VPN