How to make to work the Intel I210-T1 in CentOS 8?

The crux of the problem: cannot get working network adapter I210-T1 server with CentOS 8.

The input data and my configuration steps:
  1. Hardware: asus z170i, NIC is plugged in slot x16 slots
  2. OS: CentOS 8, Linux core 4.18.0-147.8.1.el8_1.x86_64 #1 SMP Thu Apr 9 13:49:54 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
  3. lspci-nn | grep Eth:
    00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-V [8086:15b8] (rev 31) - NIC motherboard
    01:00.0 Ethernet controller [0200]: Intel Corporation I210 Gigabit Network Connection [8086:1533] (rev 03) - problem NIC
  4. Driver NIC a:
  5. How put driver:
    • cd /home/user/Downloads
    • rpmbuild -tb igb-
      the output of rpmbuild
      everything seems fine except a couple of Warning's. Completed successfully:
      warning: Macro expanded in the comment on line 15: %define debug_package %{nil}
      /sbin/ldconfig: Warning: ignoring configuration file that cannot be opened:/etc / No such file or directory

    • cd /root/rpmbuild/RPMS/x86_64/
    • rpm-Uvh igb-
    • dnf localinstall igb-

  6. Conclusion according to the established module, swears only by the lack of signature, as I understand is the norm
    dmesg | grep igb
    [ 3.595657] igb: loading out-of-tree module taints kernel.
    [ 3.595708] igb: module verification failed: signature and/or required key missing - tainting kernel
    [ 3.614113] igb 0000:01:00.0: PCI->APIC IRQ transform: INT A -> IRQ 16
    [ 3.659516] igb 0000:01:00.0 eth0: mixed HW and IP checksum settings.
    [ 3.659597] igb 0000:01:00.0: added PHC on eth0
    [ 3.659598] igb 0000:01:00.0: Intel(R) Gigabit Ethernet Linux Driver
    [ 3.659599] igb 0000:01:00.0: eth0: (PCIe:2.5 GT/s:Width x1)
    [ 3.659600] igb 0000:01:00.0 eth0: MAC: 68:05:ca:b0:bc:1b
    [ 3.659726] igb 0000:01:00.0: eth0: PBA No: G65055-011
    [ 3.662041] igb 0000:01:00.0: LRO is disabled
    [ 3.662043] igb 0000:01:00.0: Using MSI-X interrupts. 1 rx queue(s), 1 tx queue(s)
    [ 4.212320] igb 0000:01:00.0 eth0: mixed HW and IP checksum settings.
    [ 4.212372] igb 0000:01:00.0 enp1s0: renamed from eth0
    [ 19.722924] igb 0000:01:00.0 enp1s0: mixed HW and IP checksum settings.
    [ 25.607251] igb 0000:01:00.0 enp1s0: mixed HW and IP checksum settings.
    [ 44.985047] igb 0000:01:00.0 enp1s0: igb: enp1s0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX

  7. See the NIC in ifconfig in the RUNNING state, BUT the ip address etc. he has not received unlike the built in NIC a:
    ifconfig enp1s0
    enp1s0: flags=4163 mtu 1500
    ether 68:05:ca:b0:bc:1b txqueuelen 1000 (Ethernet)
    6804 bytes RX packets 2043334 (1.9 MiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 0 bytes 0 (0.0 B)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

  8. Try to configure the NIC using the utility nmtui, but opening it do not see this adapter in the list

At this point, I finally stuck with a setup. Found an article that this problem helps to specify the start parameter "acpi=off", but it didn't help.
I have no understanding of what to do next, as similar manipulations with drivers and kernel modules new for me, and the Internet only the instructions"next>next>finish" which is not applicable in this situation.

Please help to understand. I think I have a couple of teams from this big problem installing a NIC, but the emphasis does not see the right path.
April 19th 20 at 12:03
1 answer
April 19th 20 at 12:05
but just in the forehead
nmtui - edit connections - add - Ethernet
well, to put it in settings the new adapter, the Mac address it seems 68:05:ca:b0:bc:1b
5e969a8524108047199808.png - monserrate.Stoltenberg commented on April 19th 20 at 12:08
After restarting a NIC and NetworkManager, it works!
Thank you very much. - monserrate.Stoltenberg commented on April 19th 20 at 12:11

Find more questions by tags CentOSIntelLinux