How to put the webkit qt4 on Ubuntu 18?

Hello.
There is a legacy project. Moved to udalenku. All set, and qt4.8.7 do not pull in webkit. I do not understand what to do.
List of installed libraries:
spoiler

libqt4-dbus/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-DRI/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-DRI-gestures/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-DRI-particles/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-designer/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-dev/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed]
libqt4-dev-bin/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-help/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed]
libqt4-network/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed]
libqt4-opengl/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-opengl-dev/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-qt3support/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-script/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-scripttools/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-sql/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-sql-mysql/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-sql-psql/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed]
libqt4-sql-sqlite/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-svg/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-test/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-xml/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
libqt4-xmlpatterns/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
python-qt4/bionic,now 4.12.1+dfsg-2 amd64 [installed, automatic]
python-qt4-dbus/bionic,now 4.12.1+dfsg-2 amd64 [installed, automatic]
qt4-default/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed]
qt4-demos/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed]
qt4-designer/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
qt4-dev-tools/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
qt4-doc/bionic,bionic,now 4:4.8.7+dfsg-7ubuntu1 all [installed, automatic]
qt4-doc-html/bionic,bionic,now 4:4.8.7+dfsg-7ubuntu1 all [installed]
qt4-linguist-tools/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed, automatic]
qt4-qmake/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed]
qt4-qmlviewer/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [installed]

gir1.2-javascriptcoregtk-4.0/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [installed, automatic]
gir1.2-WebKit 2-4.0/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [installed, automatic]
libglib-object-introspection-perl/bionic,now 0.044-2 amd64 [installed, automatic]
libjavascriptcoregtk-1.0-0/bionic,now 2.4.11-3ubuntu3 amd64 [installed, automatic]
libjavascriptcoregtk-1.0-dev/bionic,now 2.4.11-3ubuntu3 amd64 [installed, automatic]
libjavascriptcoregtk-4.0-18/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [installed, automatic]
libqt5webchannel5/bionic,now 5.9.5-0ubuntu1 amd64 [installed, automatic]
libqt5webkit5/bionic,now 5.212.0~alpha2-7ubuntu1 amd64 [installed, automatic]
libqtwebkit4/bionic,now 2.3.2-0ubuntu13 amd64 [installed]
libqtwebkit4-dbg/bionic,now 2.3.2-0ubuntu13 amd64 [installed]
libwebkit2gtk-4.0-37/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [installed, automatic]
libwebkitgtk-1.0-0/bionic,now 2.4.11-3ubuntu3 amd64 [installed, automatic]
libwebkitgtk-dev/bionic,now 2.4.11-3ubuntu3 amd64 [installed]

April 19th 20 at 12:05
1 answer
April 19th 20 at 12:07
Well, something like:
sudo apt-get install -y libqt4-webkit
Or libqtwebkit4

I just don't know where the Ubuntu packages are called. I have a different operating system and so the package called libQtWebKit4.
As I wrote in the question, these are the packages I have are
libqtwebkit4/bionic,now 2.3.2-0ubuntu13 amd64 [installed]
libqtwebkit4-dbg/bionic,now 2.3.2-0ubuntu13 amd64 [installed]
libwebkit2gtk-4.0-37/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [installed, automatic]
libwebkitgtk-1.0-0/bionic,now 2.4.11-3ubuntu3 amd64 [installed, automatic]
libwebkitgtk-dev/bionic,now 2.4.11-3ubuntu3 amd64 [installed]
- Mallie.Bechtelar commented on April 19th 20 at 12:10
@Mallie.Bechtelar, This means that the package WebKit you have installed in the system. Disagree, the question is answered.

What and where do not pull WebKit? How it manifests itself. You understand that the question should be how do you add a bug to the tracker, according to the algorithm: "In this environment... I'm doing 1, 2, 3... get something... expected something." Otherwise it will be incomplete and it will not be able to answer. - Emily commented on April 19th 20 at 12:13
@Emily, In a pro project file connect module WebKit QT += webkit In the. cpp file in the project to connect the library and module WebKit #include <QWebView> And get the error build error: QWebView: No such file or directory - Mallie.Bechtelar commented on April 19th 20 at 12:16
Then we have to see the Makefile that there is generated, in what ways. I assume that the kit you have soberit the correct version of Qt. In addition, it would be nice to make sure that the webview is connected this way: QT += webkit. In the documentation you can find. - Emily commented on April 19th 20 at 12:19
@Emily,
In addition, it would be nice to make sure that the webview is connected this way: QT += webkit.

Qt 4.8.7 exactly.
https://doc.qt.io/archives/qt-4.8/qtwebkit-module.html - Mallie.Bechtelar commented on April 19th 20 at 12:22
@Mallie.Bechtelar, Well, now only to watch the Makefile or compiler command that is executed. Then verify that the correct path and the like. - Emily commented on April 19th 20 at 12:25

Find more questions by tags QtWebkit