Just me does not work switching of keyboard layout left to first layout ctrl, right ctrl to last layout?

Is the newest version of CentOS 7, gnome 3.28, kernel 5.6.3-1.el7.elrepo.x86_64.

Now the switch works on CapsLock.

Tried all the available options in gnome-tweaks, nothing works.

Any attempts to link Russian and English to various keys - nothing.
For example, Caps eng, Shift-Caps - eng - does not work
Option "left to first layout ctrl, right ctrl to last layout" - disables Ctrl from keyboard combinations. But switching still doesn't work.

Is there a way to allocate each language has its own way to switch?
April 19th 20 at 12:08
2 answers
April 19th 20 at 12:10
try XNeur via GUI or with gXNeur ,
there are options to set a layout for each language installed on the system
look in /etc/xneur/xneurrc or ~/.xneur/xneurrc
AddBind EnableLayout1
AddBind EnableLayout2
etc.
PS
what do you like changing in caps ?
April 19th 20 at 12:12
Thanks for the advice.

XNeur was not able to put on CentOS 7. Search for errors, nothing gives.

For caps not convenient for those that need to check for the current language.

Libraries installed but the build from source fails with errors. Overcome one, another POPs up. Was not such a program stuff kicks in. A dead end road. I'll look for a bug in the system or try ppl were xneur.

Find more questions by tags CentOSGnomeLinux