How to fix the stretched textures?

I'm sure I'm doing it wrong, and I would be grateful if you tell me how.
I take create a Cube object, ask him the size 150x1x0.5. Find in the Internet any finish such as brick. Import in Unity when you import the texture should check Warp type: Repeat.
Create a Standard material from the texture. And apply to that cube. The texture is stretched over the entire cube. How to do that it would be repeated and not stretched? Yes, I see that there is a parameter in the Render Mesh - Tail, and there you can set the texture started to repeat. But it is impossible to do more right? That would be regardless of the size of the object, it is not stretched?
April 19th 20 at 12:22
1 answer
April 19th 20 at 12:24
Solution
Use the Tiling and Offset parameters to control the size of the texture.

Here's another:
... what is UV, normal map, baking?

Find more questions by tags Unity Game Engine