To change the limits (ulimit) for the root user for RHEL?

Hi all, was experimenting with setting limits /security/limits.conf, set the root parameter nofile -1, now can't log in :), the server has other users, but they don't ship Respected the community, tell me how if you change user with the command su - root , it is possible to prescribe limits (Perhaps using setrlimit)? Well, or tell me the options for how this parameter can be return/change. Thank you!
April 19th 20 at 12:30
2 answers
April 19th 20 at 12:32
Solution
Never experiment with root

Open the server console.
Reboot.
To enter the mode of single (or emergency).
To mount a file system (or at least / remount in rw)
To correct limits.conf
Reboot.

And more never to experiment with root
April 19th 20 at 12:34
One of the two
1) reboot in single user mode and fix
2) boot from resque disk, mount the system drive and restore

Find more questions by tags * nix-like systemsRed Hat Enterprise LinuxLinux