How to catch error Composer?

Got out some garbage, when composer update or add a new package climbs error
Error Composer
[Composer\Repository\InvalidRepositoryException] 
No valid bower.json was found in any branch or tag of https://github.com/DmitryBaranovskiy/eve.git, 
could not load a package from it.


The composer is configured to work with asset-packagist.org

If removed from the composer.json
{
 "type": "composer",
 "url": "https://asset-packagist.org"
 }

that is what the package is killed?
June 14th 19 at 18:08
1 answer
June 14th 19 at 18:10
Solution
Good afternoon.
Is it?
"require": {
 "bower-asset/bootstrap": "^3.3",
 "npm-asset/jquery": "^2.2"
}

And check bower.json, the problem is this file supposed to be.
neither one nor the other - Mohamed_Lind75 commented on June 14th 19 at 18:13
documentation indicated that these lines should be those that You have.
here - Dion77 commented on June 14th 19 at 18:16
, this is an example given -- neobhodimym Ampacity and a line for the direction of the Composer...

still worked, just became oshikai spit...

Yes. interposed-does not work expected - Mohamed_Lind75 commented on June 14th 19 at 18:19
and syntax bower file? - Dion77 commented on June 14th 19 at 18:22
anything I do not understand -- on a VPS, all fine,
deleted the local project, pulled again from the Gita and its the same error

syntax bower(.bowerrc):
{
 "directory" : "vendor/bower"
}

changed to bower-assets, the same error:) - Mohamed_Lind75 commented on June 14th 19 at 18:25
and the plugin may not interfere? - Dion77 commented on June 14th 19 at 18:28
also thought I'd need to carry... - Mohamed_Lind75 commented on June 14th 19 at 18:31
try, because asset-packagist as a replacement for the plugin, maybe there is a conflict. - Dion77 commented on June 14th 19 at 18:34
, thank you very much :)
Yes, the plugin interfered with the work of the composer - Mohamed_Lind75 commented on June 14th 19 at 18:37
please. - Dion77 commented on June 14th 19 at 18:40

Find more questions by tags ComposerPHP