Do not open some sites on Ubuntu 17.04 — what to do?

Some sites work through times (in most case).
Sites that don't work:
https://login.live.com (because of this, Skype does not start)
https://developer.mozilla.org

ping https://login.live.com
59d79892413c6626816582.pngping https://developer.mozilla.org
59d798e68e455137024572.png

I tried different browsers.
59d79911b8d2d142798829.png
June 14th 19 at 19:18
4 answers
June 14th 19 at 19:20
The first ping you need to use this:
ping developer.mozilla.org
Specifying the Protocol, you will always get host unknown.

I would check DNS:
nslookup developer.mozilla.org
and
nslookup developer.mozilla.org 8.8.8.8
https://login.live.com now working, but it will take some time and again will get error.

59d79e1295015678056488.png59d79e29a06ef670591199.png - Ellen_Bashirian68 commented on June 14th 19 at 19:23
you have something with DNS, set the DNS 8,8,8,8 interfase and it should work - alia98 commented on June 14th 19 at 19:26
, this shows that you have a dns server (127.0.0.53) for some reason doesn't want to resolvit developer.mozilla.org
Or repair or replace it in the settings - kyla.Torp commented on June 14th 19 at 19:29
he will have to cut systemd - this is his mess - astrid_Sawayn commented on June 14th 19 at 19:32
Probably talking about this: systemd-resolved appends 127.0.0.53 to resolv.conf... - gustave_Kertzmann52 commented on June 14th 19 at 19:35
June 14th 19 at 19:22
https://github.com/systemd/systemd/issues/5755 - demolition of Ubuntu and put Devuan or something else "free of systemd"
Not necessarily "free of systemd". On Debian Stable there is no problem. - Ellen_Bashirian68 commented on June 14th 19 at 19:25
well and systemd is not only fun with DNS. https://twitter.com/backupbear/status/903353075917... - no wonder Pwnie award took - alia98 commented on June 14th 19 at 19:28
Yes , I know. Just have TS specific problem. In Debian it is not, although there is a facial joints too vpendyurit, unfortunately.. - kyla.Torp commented on June 14th 19 at 19:31
June 14th 19 at 19:24
Go to the settings of the network interface in the MTU field, enter 1448. Click save.
Don't thank
June 14th 19 at 19:26
In the network settings in the "Cloning MAC address" and hit "random." Helped me.

Find more questions by tags LinuxUbuntu